Start error on win10

my Install on win 10 was succesful but program not starting ; window pops up briefly and close himself.
after install a window with message “Angegebener PFad konnte nicht gefunden werden” was closed.
Thanks

Hey and welcome to the community.

Looks like you are trying your luck on a german installation. I am not sure which path it couldn’t find. Can you be more specific about how you run the system?

Most likely, however, you either did not set the JAVA_PATH variable (https://www.mkyong.com/java/how-to-set-java_home-on-windows-10/), or the folder you used for the installation contains spaces, so the start script may not wrap it correctly (this is less likely, however, as I am not aware of issues of the sorts).

Please also make sure that you follow each step of our install instructions. It is easy to miss the installation.bat step and that may result in more errors even if you solve the issue thrown here…

i try to run in Windows start scipio - erp start:
grafik

The JAVA_Home Path have any spaces (but is was required and necessary for installation):
C:\Program Files (x86)\Common Files\Oracle\Java\javapath

the installation was finished correctly.
But now im searching for some files to start or config it anyway but i cant find any files or folders of scipio in my drive

That java_home directory looks odd to me. Usually it contains the JDK info. So something like
C:\Program Files\Java\jdk1.8.0_65 (please make sure to use JDK 1.8 - JAVA 9-12 are not supported atm). Open up a new console window and type “java -version”. It should return the java version - otherwise you got a problem with the location you defined.

You should be able to right click the “Scipio ERP start” file and select properties / Einstellungen from the popup menu. It should give you the path the program is located at.

i make install complete again with new pathes but also become the same error:

“C:\Programme\Java\jdk1.8.0_221/bin\bin\java” -jar “C:\Users\FK\SCIPIO~1\framework\base\lib\ant\ant-1.10.2-ant-launcher.jar” -lib “C:\Users\FK\SCIPIO~1\framework\base\lib\ant” -lib “C:\Users\FK\SCIPIO~1\framework\base\lib\oro-2.0.8.jar” start
Das System kann den angegebenen Pfad nicht finden.
C:\Users\FK\ScipioERP>

Your path is still wrong (note the /bin\bin). Please update your java path without the “bin”

1 Like

starts and finish compiling but:
Couldn’t create server socket(/127.0.0.1:10523) (Address already in use: JVM_Bind)

complete output:

C:\Users\FK\ScipioERP>echo off

C:\Users\FK\ScipioERP>“C:\Programme\Java\jdk1.8.0_221\bin\java” -Xms128M -Xmx3512M -Xdebug -Xnoagent -Dsolr.solr.home=applications/solr/ -Dsolr.log.dir=runtime/logs/solr/ -Dsolr.lock.type=single -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=8091 -jar ofbiz.jar
Listening for transport dt_socket at address: 8091
Start.java using configuration file org/ofbiz/base/start/start.properties
Set OFBIZ_HOME to - C:/Users/FK/ScipioERP
Exception in thread “main” org.ofbiz.base.start.StartupException: Couldn’t create server socket(/127.0.0.1:10523) (Address already in use: JVM_Bind)
at org.ofbiz.base.start.Start$AdminPortThread.(Start.java:484)
at org.ofbiz.base.start.Start.createListenerThread(Start.java:160)
at org.ofbiz.base.start.Start.init(Start.java:228)
at org.ofbiz.base.start.Start.main(Start.java:130)
Caused by: java.net.BindException: Address already in use: JVM_Bind
at java.net.DualStackPlainSocketImpl.bind0(Native Method)
at java.net.DualStackPlainSocketImpl.socketBind(DualStackPlainSocketImpl.java:106)
at java.net.AbstractPlainSocketImpl.bind(AbstractPlainSocketImpl.java:387)
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:190)
at java.net.ServerSocket.bind(ServerSocket.java:375)
at java.net.ServerSocket.(ServerSocket.java:237)
at org.ofbiz.base.start.Start$AdminPortThread.(Start.java:482)
… 3 more

Now it seems as if you already have another application running that are blocking the port. You must have changed our config to use port 10523 (scipio uses 8080 or 8443 by default).

1 Like

i have change port in

Global URL Configuration

All configuration can be set inside of /framework/webapp/config/url.properties:

HTTPS Port (Secure port)

port.https.enabled=Y
port.https=8443
force.https.host=

HTTP Port (Not Secure port)

port.http=10523
force.http.host=

but it is also does not work
browser-output in localhost:10523 is “FAIL”

Ok, well the error you receive is because another application or your firewall is blocking the port (possibly you started scipio before and forgot to stop).

Also be aware, that it is also not enough to change the url.properties as that only affects how urls are generated, not how the webserver starts. Did you follow this handy guide: https://www.scipioerp.com/community/developer/installation-configuration/configuration/#url-configuration
?

1 Like

But nothing happend (waiting min 1 h)(What is still to be done to start in browser?)


SCIPIO ERP Community Edition 2.0.0 (dev branch) FRAMEWORK IS LOADED


  • Please wait for any startup jobs to finish…

2019-10-10 05:39:56,884 |Scipio-JobPoller |JobManager |I| No crashed jobs to re-schedule
2019-10-10 05:39:56,946 |Scipio-JobPoller |JobManager |I| Scipio: Collected 1 SCH_EVENT_STARTUP run-at-startup jobs for queuing
2019-10-10 05:39:57,180 |Scipio-JobQueue-0 |SequenceUtil |I| Got bank of sequenced IDs for [JobSandbox]; curSeqId=10100, maxSeqId=10200, bankSize=100
2019-10-10 05:39:57,196 |Scipio-JobQueue-0 |PersistedServiceJob |I| Running Job [SOLR index rebuild run-at-startup job] Id [10001] Service [rebuildSolrIndexAuto] Retries [0/-1] – Next recurrence: Thu Oct 10 05:39:58 CEST 2019
2019-10-10 05:39:57,259 |Scipio-JobQueue-0 |UtilProperties |I| ResourceBundle DefaultMessages (en) created in 0.047s with 11 properties
2019-10-10 05:39:57,290 |Scipio-JobQueue-0 |AbstractEngine |I| Loaded Service Locations: {eedcc-test=https://localhost:8443/admin/control/httpService, entity-sync-http=https://localhost:8443/admin/control/httpService, rita-rmi=rmi://localhost:1099/RMIDispatcher, main-rmi=rmi://localhost:1099/RMIDispatcher, main-soap=http://localhost:8080/admin/control/SOAPService, entity-sync-rmi=rmi://localhost:1099/RMIDispatcher, main-http=http://localhost:8080/admin/control/httpService}
2019-10-10 05:39:57,352 |Scipio-JobQueue-0 |SolrProductSearch |I| Solr: rebuildSolrIndexAuto: Launching index check/rebuild (onlyIfDirty: true, ifConfigChange: true, waitSolrReady: true)
2019-10-10 05:39:57,384 |Scipio-JobQueue-0 |UtilProperties |I| Property [solrconfig/solr.webapp.portOverride] empty; using defaultNumber null.
2019-10-10 05:39:57,399 |Scipio-JobQueue-0 |SolrUtil |I| Solr: Determined Solr webapp URL: http://localhost:10523/solr
2019-10-10 05:39:57,430 |Scipio-JobQueue-0 |ServiceDispatcher |T| Sync service [default/rebuildSolrIndex] finished in [78] milliseconds
2019-10-10 05:39:57,430 |Scipio-JobQueue-0 |SolrProductSearch |I| Solr: rebuildSolrIndexAuto: rebuildSolrIndex returned success: SOLR data is already marked OK; SOLR data is already at config version 1.0.19; not rebuilding
2019-10-10 05:39:57,430 |Scipio-JobQueue-0 |ServiceDispatcher |T| Sync service [default/rebuildSolrIndexAuto] finished in [140] milliseconds

:slight_smile:

I can see it at:
https://localhost:8443/admin/control/main

Thank You for your very patent help

Alright, but just a quick heads up: While checking your log entries, it looked to me as if you are still mixing ports. So your config may not be completely done. If you are experiencing any issues (eg with the shop not showing products) make sure to go back and adapt all port settings.

Then again: i am not sure how your port settings are supposed to be, so all could be fine as well. Glad if it works for you :slight_smile: