Shop catalog hierarchy


#1

@madppiper I looked at the demo site and reworked my catalog & category set up to be Amsoil Catalog --> Oil, Air Filters, (children), etc.

On my shop page it shows OIL on the main page but then comes up empty when I click on it and definitely does not offer any of the 16 other children categories. Oddly enough I can search for all my products and they show up but not under any category.

I have a few dozen across all categories marked as not requiring inventory for testing purposes.

I have the children listed child under Amsoil Catalog (as the parent).
I have also restarted scipio multiple times in case it was necessary for the changes to take effect.

What else should I look at?

image image image


#2

It’s easier to visualize if you look at the Catalog manager dashboard or the Catalog step on the Setup app. The child categories should be two layers down from top node like this:
Screenshot_2018-11-21_20-34-25

The fact “Oil” comes up as a top category on /main suggests it’s associated to the catalog as a “top” category which would be wrong here. I think you’re missing the “top” category between the ProdCatalog and the children categories.

You usually don’t have to full restart to see changes, go to /admin/control/FindUtilCache and click Clear All Caches.

If I don’t respond tonight, paul will be on several hours later.


#3

Here is mine… I guess that is the problem, I am missing a category…

image


#4

Yeah, that’s the problem. You have to make a single top catalog category (“Catalog”/“Browse Root”), the other tops are special ones like best-sell, etc. In the Setup catalog step it looks like this:
Screenshot_2018-11-21_21-12-20


#5

OK, some progress but it still doesn’t expand in the Store/Site. Should I have options underneath the Catalog Manager?

image
image


#6

Could be a few things…

  • categories only show on the left if they contain at least 1 product
  • (This probably isn’t the issue, happens automatically, but you have to know anyway) The categories are gotten from Solr and if something goes wrong you have to reindex it at: /admin/control/SolrServices and under “rebuildSolrIndex” click “Run Service” button - can try along with cache clear

#7

That did it, thank you! I’ll leave everything alone for now and let you enjoy holiday.

image


#8

Great! If solr rebuild worked, is probably because the automatic update (eca) got bypassed somehow, not sure which action could have bypassed that here. But the rebuildSolrIndex always works.