Scipio in grails


#1

Hello, i have just installed scipio. Followed the installation instruction but i can no have scipio run.
Also i want to use some scipio logic to implement in grails but when i browse through web, i can not see the relation between the urls and scipio files i downloaded. Any help i am new to scipio


#2

Hi,

and welcome to the community. So first things first, you checked out scipio erp from github I assume. Did you run the install script? (script.sh or script.bat for windows) I highly recommend to install with demo data as a start, as it allows you to familiarize yourself with everything before doing your own custom installation.

About the urls: Have a look at the following handy guide https://www.scipioerp.com/community/developer/views-requests/request-controller/


#3

I should mention, i really recommend to read up on the framework itself starting with https://www.scipioerp.com/community/developer/architecture/ and to work your way down the developer resources. They are meant as a nifty guide to explain the core concepts and really a good starting point for anybody new.


#4

Hi madppiper, i cloned scipio from github and i installed using install.bat in windows


#5

Thank you. Let me start reading first, and i got an error when i tried to run scipio on the browser. Error 404 even though the build was successful after i had run install.bat


#6

Ok, and you started the server with start.bat and everything, correct? what url did you enter? What does the log say (should be printed out in commandline after starting the application - have a look for error messages)


#7

here is the error message
“C:\Program Files\Java\jdk1.8.0_191\bin\java” -Xms128M -Xmx3512M -XX:MaxPermSize=1024m -Xdebug -Xnoagent -Dsolr.solr.home=applications/solr/ -Dsolr.log.dir=runtime/logs/solr/ -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=8091 -jar ofbiz.jar
Java HotSpot™ 64-Bit Server VM warning: ignoring option MaxPermSize=1024m; support was removed in 8.0
Listening for transport dt_socket at address: 8091
Start.java using configuration file org/ofbiz/base/start/start.properties
Set OFBIZ_HOME to - C:/Users/Msuta/scipio-erp
Exception in thread “main” org.ofbiz.base.start.StartupException: Couldn’t create server socket(/127.0.0.1:10523)
at org.ofbiz.base.start.Start$AdminPortThread.(Start.java:484)
at org.ofbiz.base.start.Start.createListenerThread(Start.java:160)
at org.ofbiz.base.start.Start.init(Start.java:228)
at org.ofbiz.base.start.Start.main(Start.java:130)
Caused by: java.net.BindException: Address already in use: JVM_Bind
at java.net.DualStackPlainSocketImpl.bind0(Native Method)
at java.net.DualStackPlainSocketImpl.socketBind(DualStackPlainSocketImpl.java:106)
at java.net.AbstractPlainSocketImpl.bind(AbstractPlainSocketImpl.java:387)
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:190)
at java.net.ServerSocket.bind(ServerSocket.java:375)
at java.net.ServerSocket.(ServerSocket.java:237)
at org.ofbiz.base.start.Start$AdminPortThread.(Start.java:482)


#8

Looks like you are already using the port for a different application. By default scipio uses ports 8080 and 8443. Do you have another tomcat server running by any chance?


#9

Although, i think in this case it seems to be the port 10523…


#10

Port 8080 is being used by grails app… I can chnage though. How do i run scipio on different port?


#11

If you want to change the ports used by scipio erp you must change:

  1. framework/catalina/scipio-component.xml (these are all the ports used by the inbuilt tomcat server)
  2. /framework/webapp/config/url.properties (this defines how urls are generated by default)

That should allow the system to start under a different port. You can also change the admin port used by java that allows you to connect for debugging purposes. That one you can find on top of the start.bat script.

For completion sake, you may also want to modify framework/service/config/serviceengine.xml, if you use soap or such…


#12

I tried to change the ports still getting the same error


#13

Well, you are still running multiple java applications alongside one another then. Did you restart the server after changing ports?

Another thing you can try is to add the following parameter to the start.bat start settings (add it after -Xdebug): -Dofbiz.admin.port=20523


#14

Oh, i just realized: if you ran the install script while the ports were blocked, the installation didn’t go through and will have ended with an error message. So please repeat the installation before starting the system.


#15

Now it’s working, i can start exploring it… if i get stuck i will ask again. Love the way you have been responding quickly… It’s my first day with Scipio