Scipio erp logout having issue in Firefox


#1

I am unable to logout of scipio when using Firefox browser.
Its weird that only the first time that i press logout, it is working.
Afterwhich when i login back again, i am unable to logout. Clicking on the logout button will only bring me back to main page.

The above behavior is experienced in scipio demo webpage. Tried it on firefox in android phone with the same result as well. Ofbiz demo however is able to pass the test without any issue.

It is working perfectly fine in chrome though.

Thanks for your kind attention


Scipio ERP 1.14.3 released
#2

Hi,

thanks for bringing this to our attention. I just checked and was able to recreate the issue on firefox. It seems as if this is only an issue after an immediate re-authentication to the same application. Switching applications will also not work, as the token that is passed for authentication, is already outdated. I was not able to reproduce this in either Internet Explorer (+ Edge) or Chrome, but I was able to recreate this locally, as well. So it has to be a weird Firefox issue.

Closing your Firefox will terminate the session.

We will look into this and post our findings here.

Regards,
Paul


#3

In terms of the request, it seems as if firefox is screwing with the /logout request. the system itself does not receive the /admin/control/logout request.

I tried posting a request via AJAX to /admin/control/logout and the session was terminated just fine. So I will dig deeper into the Firefox messageboards to check what may be the cause here.

To recreate my findings, you can terminate the session by:

  1. Open Developer console with F12

  2. click on Console

  3. type
    $.post('/admin/control/logout')

  4. Click any link, you will be asked to renter your password


#4

Found the reason: Firefox stores the 301-redirect to /control/main, which occurs after logout in cache. It seems to skip this request entirely and just rely on the cache, which is why you are returned to the dashboard. See attachment:

We can easily avoid this behavior by not redirecting and displaying a page that tells you that you logged out succesfully. I will implement a fix tomorrow and we will push to github asap


#5

Implemented a fix and updated the demo server with it. You will need to clear your browser cache in firefox for this to work.

The fix will be pushed to github asap.

Thanks for reporting this back to us!


#6

Hi,

Tested OK. Thanks for the fast respond and detailed findings.


#7

The bugfix has been pushed to github.


#8

I’m still seeing this behavior with FF. Has this been pushed to 1.14?


#9

@pplx: can you comment on this?

@mz4wheeler: The change is actually a one-liner:

\ https://github.com/ilscipio/scipio-erp/commit/f7232036b5a2da61934f1d93988433daed8b92e7

So if it hadn’t been pushed to 1.14, you should be able to fix it locally easily :slight_smile:


#10

No it was not merged to 1.14, so I have merged it to 1.14 on request now.


#12