Master - Unable to "set" Custom Time Period


#1

When a custom time period is entered, and shows up:

Accounting -> Settings -> Custom Time Period

The links for “Update” “Delete” and “Set as Current” do not render properly:

Further: “Delete” does not seem to work, nor does “Set as Current”.

“Delete” ERROR
The Following Errors Occurred:

Error calling event: org.ofbiz.webapp.event.EventHandlerException: Found URL parameter [customTimePeriodId] passed to secure (https) request-map with uri [deleteCustomTimePeriod] with an event that calls service [deleteCustomTimePeriod]; this is not allowed for security reasons! The data should be encrypted by making it part of the request body (a form field) instead of the request URL. Moreover it would be kind if you could create a Jira sub-task of https://issues.apache.org/jira/browse/OFBIZ-2330 (check before if a sub-task for this error does not exist). If you are not sure how to create a Jira issue please have a look before at http://cwiki.apache.org/confluence/x/JIB2 Thank you in advance for your help.

“Set as Current” ERROR
reeMarker template error: The following has evaluated to null or missing: ==> hasntStarted [in template “component://accounting/webapp/accounting/period/EditCustomTimePeriod.ftl” at line 48, column 22] ---- Tip: If the failing expression is known to be legally refer to something that’s null or missing, either specify a default value like myOptionalVar!myDefault, or use <#if myOptionalVar??>when-present<#else>when-missing</#if>. (These only cover the last step of the expression; to cover the whole expression, use parenthesis: (myOptionalVar.foo)!myDefault, (myOptionalVar.foo)?? ---- ---- FTL stack trace ("~" means nesting-related): - Failed at: #if hasntStarted [in template “component://accounting/webapp/accounting/period/EditCustomTimePeriod.ftl” at line 48, column 17] ~ Reached through: #nested [in template “component://common/webcommon/includes/scipio/lib/standard/htmlStructure.ftl” in macro “section” at line 837, column 45] ~ Reached through: #nested [in template “component://common/webcommon/includes/scipio/lib/standard/htmlStructure.ftl” in macro “section_core” at line 1176, column 71] ~ Reached through: #nested [in template “component://common/webcommon/includes/scipio/lib/standard/htmlStructure.ftl” in macro “section_markup_container” at line 1268, column 13] ~ Reached through: @section_markup_container type=type s… [in template “component://common/webcommon/includes/scipio/lib/standard/htmlStructure.ftl” in macro


#2

Confirmed, a fix coming soon too for this.


#3

After looking at this in a more deeper way I just realized that the entire screen required a big overhaul.
I am almost done with that but more testing is required before it hits our git repo. I will ping you once it does.


#4

Looks like I still can’t “set” the time period. This is pretty major from an accounting perspective.


#5

Have you tried the Settings section? Perhaps you can clarify which parts don’t work? Is it still the delete and add functionality?

@minifreak: Could you take a second look, too?

https://ce.scipioerp.com/accounting/control/EditCustomTimePeriod?organizationPartyId=Company


#6

Yup. Got it. I was confused by “Custom Time Period” and “Time Period” sub-menus. Since they are related, maybe they should appear close to each other on the sub-menu. Maybe call them “Time Period - Update” and “Time Period - Set”?


#7

That sounds like a good idea. Will do.


#8

Changed - will be pushed to github with the next update.