Install of Scipio ERP


#1

Hello All,

I am somewhat new to this side of computers and web development. I am helping to start a new business and we wanted to use SCIPIO ERP as our solution. I was hoping to host it along side our website on a subdomain but alas our web host doesn’t allow JAVA installations without upgrading our plan (I am a little frustrated, but will find the right plan eventually). Until we figured out a solution, I was hoping host Scipio locally on a mac. I was able to launch Scipio successfully utilizing the terminal to install and launch but would like a solution that doesn’t involve launching the terminal or being a programmer to open Scipio. I saw a download for Scipio for Mac on the website and downloaded it. I can’t install because it doesn’t recognize my Java. I have installed java and ensured that the JAVA_HOME variable is set correctly. All of that works, yet the installer is halting me. Any help is appreciated.

41%20PM
23%20PM


#2

Hey and welcome to the community,

good to have you. Now, did you install the JDK or JRE? Unfortunately there are two “versions” of java - one for running java (Java Runtime Edition) and one for compiling and running (Java Developer Kit, or JDK). We need the latter. I am not working on a Mac, so I will have to wait for others to comment, but you should be able to download and install the JDK from oracle:

http://www.oracle.com/technetwork/java/javase/downloads/index.html (Note the “JDK” download link)

You can test if you have the JDK installed by running:

javac -version

from command line. “java -version” on the other hand will only tell you if a JRE is installed.


#3

Hello! Thank you for the kind welcome! I do indeed have JDK installed.

Upon running your terminal request, I received the following reply.

48%20AM


#4

Ok, interesting. The installers are supposed to pick this up. I will ask one of the fellow mac developers (@rentonize) to look into it.

In the meanwhile: you can also install from sources. It is actually the recommended way, as it allows us to supply you with fixes more often.

So try checking out the project from git (https://github.com/ilscipio/scipio-erp) - use the master branch for now. The download and installation instructions are outlined in the README and easy to follow. The only real difference is that this method lacks a GUI and you will have to manually set the configuration properties, but that’s all written down in the docs as well (https://www.scipioerp.com/community/developer/installation-configuration/). Since you are new to the system, I recommend installing with demo data.


#5

Hi @jphudson

I am able to reproduce the issue on an OS X 10.13.6 platform with Java 1.8.0_101-b13. That most likely means that we will have to fix the installer.

Thank you for reporting the issue and please excuse any inconvenience.


#6

We updated the mac os installer. Please retry and let us know if you continue to run into issues. That being said: we still recommend using the github version, but I guess you can check out the installer, too.


#7

Thank you for the quick reply and update on the installer. I have attached the error I am receiving when trying to install overlaid with the java and javac so you can see what’s currently installed and working. This is from the new download on the webpage. I couldn’t even get the installer to launch now. No changes on my end.

I have already installed from github via command line and evaluated whether it would work for the company [and was ecstatic to see that it existed] , but am seeking a solution that allows me to launch scipio without having to use terminal or keep a terminal window open. I am not sure how to do that at the moment.

10%20PM


#8

Hey,

ok, that’s a shame. There is a slight chance that macOS is handling the java installation differently now, so our installer (we use a really good tool by the name of install4j) may not be able to pick it up anymore. We didn’t receive the error internally, so thank you alot for the feedback - that is golden!

You can easily start the software as a service - take a look inside the runtime directory. We got a variety of shell scripts there that do exactly that (just copy the right one to a directory of your choice and use an editor to open the file - there are a few parameters on top, which you may want to modify). And if you require any additional help with the shell scripts, we are here to support.

So double checking: installation via github works fine, right? :slight_smile:


#9

Absolutely! Installation over github worked just as the readme specified.

Unfortunately, I am a little green to understand the terminology you speak of to start Software as a service. i get the concept but am unsure of the process as to how to execute. Do you know of any resources that would help in this area?

Thank you so much for your timely and effective responses!


#10

Glad it worked out. I just replied to your other question - looks like you got it figured out already :slight_smile: