First time install issues


#1

So far, this isn’t blowing my skirt up.

Debian Jessie, fresh install on AMD64 especially for the purpose of running SCIPIO.

Issue 1:

I already have a population of about 25,000 products in a Postgres database so first I want to configure SCIPIO to use Postgres instead of Derby.

In ./framework/entity/config/entityengine.xml it says:

" - This file configures the Entity Engine JDBC (or other DataSource) and JTA
access. For a detailed description see the core/docs/entityconfig.html file."

There is no such file in the distribution:

howler:~/tgz$ >>> unzip -l scipio-erp-master.zip | grep -i entityconfig.html
howler:~/tgz$ >>>

So I don’t know what to do to use Postgres instead of Derby. What do I do?

Issue 2:

I gave up trying to get the forum software to quote this, all it managed was the first couple of lines at best:

[EXTRACT]
howler:~/src/ofbiz/scipio-erp-master$ >>> ./install.sh

INSTALLER

Please make a selection

  1. Install for development [compile, load seed & demo data]
  2. Install for production [compile, load seed]

  1. Recompile [compile]
  2. List ant compiler information

==========PRESS ‘5’ TO QUIT==========

  1. Install for Development 4) List ant info
  2. Install for production 5) Q
  3. Recompile
    Please select a number: 5
    invalid option
    Please select a number: 4
    ./install.sh: line 57: ant: command not found
    Please select a number:
    [/EXTRACT]

The install.sh script seems to be rather broken, so I hit CTRL-C and wrote this post… :frowning:


#2

Hi Ged,

sorry to hear you got problems with the installation. We released a bugfix to the installer on friday. Can you update your version? I recommend to use git to checkout our source, that way you can pull the next version.

Taking from your output, however, it may be that you do not have the prerequisits installed correctly. Did you install apache ant and export the variable?

About the db configuration: In order to configure your database please go to \framework\entity\config\entityengine.xml

Replace “localderby” with "localpostgres in the delegator definitions:

<delegator name="default" entity-model-reader="main" entity-group-reader="main" entity-eca-reader="main" distributed-cache-clear-enabled="false">
        <group-map group-name="org.ofbiz" datasource-name="localpostgres"/>
        <group-map group-name="org.ofbiz.olap" datasource-name="localpostgresolap"/>
        <group-map group-name="org.ofbiz.tenant" datasource-name="localpostgrestenant"/>
    </delegator> 

Then update the localpostgres definition later in the same file. Please be aware that you will have to download the postgres JDBC driver for this to work. There is an ant command that will do this for you:

./ant download-PG-JDBC


#3

Perhaps it is also worth noting that if you used Apache OFBiz before, you can still rely on the same configuration & installation methods you used previously.


#4

and you are right, the darn forum strips our tags… i will ask our sys admin to check on that


Update: turns out you got to use the preformatted text option for the code to be displayed - a security issue


#5

Hi Paul,

Some of the output in my post got lost in, er, translation. Yes I have Ant installed, but I don’t know what you mean by “export the variable”. Do you meant JAVA_HOME? in which case yes, I did. If there’s another variable to be exported I don’t see it in the README. At the moment I’m pretty desperate for documentation.

[QUOTE]
howler:~/src/ofbiz/scipio-erp-master$ >>> export JAVA_HOME=/usr/lib/jvm/java-7-openjdk-amd64
howler:~/src/ofbiz/scipio-erp-master$ >>> ./install.sh
[snip,snip]
============ INSTALLER ==============
Please make a selection

  1. Install for development [compile, load seed & demo data]
  2. Install for production [compile, load seed]
  3. Recompile [compile]
  4. List ant compiler information
    ==========PRESS ‘5’ TO QUIT==========
  1. Install for Development 4) List ant info
  2. Install for production 5) Q
  3. Recompile
    Please select a number: 4
    Unable to locate tools.jar. Expected to find it in /usr/lib/jvm/java-7-openjdk-amd64/lib/tools.jar
    [/QUOTE]

Please forgive me. For the purposes of this exercise I’m a new user. I’m OK with digging into the sources and hacking stuff, but I think you need to lead a new user by the hand a lot more than you seem to have done.

The forum software is going to take a bit of getting used to. Right now I think I’d prefer Prestel. :smile: Of course I did try the pre-formatted text option, but – well – you try it. It doesn’t seem very robust to me, and for something like this project I think it’s an important feature. If there’s a way to quote a previous post in a reply it isn’t obvious to me, and I’d find that very useful. However I do like the way the forum software handles embedded links in posts. Best I’ve seen by a long way. :smile:

Anyway since you’ve updated the installer already, then unless there’s something obvious from what I’ve put in this post that you think I’m doing wrong don’t worry about it too much. I’ll grab the latest distribution Zip file and give it another go. It will take a while - does it have to be 170megabytes?! I really don’t want to be messing around with Git at this stage, I want to do what a new user will do so the installation process gets tested at least a little bit.

Ged.


#6

You are absolutely right and your feedback is more than welcome. Our Readme file is a bit misleading with respect to the ant command. It does list Apache Ant as a prerequisite, but not that you also have to export the variable. I updated our readme so that it reads as the following in a future release:

Prerequisits
In order to install SCIPIO ERP, the following prerequisites must be installed properly:

  • Java 1.7 (or greater) SDK
  • Download and Install
  • Set JAVA_HOME Path
  • Validate Settings
  • Install Apache Ant
  • Download and Install
  • Set ANT_HOME Path

That being said here’s what you have to do to get Apache ant running on linux, you will have to also set the environment variable (taken from http://ant.apache.org/manual/install.html):

export ANT_HOME=/usr/local/ant

You will have to make sure that you are setting this for the user running SCIPIO ERP & your current user. That should allow you to run the command just fine.


About the installer itself: I really recommend to install git locally, that way you can clone our repository

git clone https://github.com/ilscipio/scipio-erp.git

and it should download the entire package for you in your folder. For future releases you can then run git pull and it will update your source with our latest changes. We are planning for regular release cycles that won’t happen daily, so it should work for your local installation. If you don’t want to do that now, because the file-size is an issue, you can also workaround by simply downloading both files directly:

https://raw.githubusercontent.com/ilscipio/scipio-erp/master/start.sh
https://raw.githubusercontent.com/ilscipio/scipio-erp/master/install.sh

There may still be one known bug with the installer, that you should be aware of: it is possible that the loop won’t exit the installer directly under certain conditions and you will be printed the menu again after the install ran through succesfully. You can safely use cntrl-c to get out of the window. We are currently trying to figure out the cause of it and will fix it in one of the next releases.


Perhaps i should mention again, how much i value this feedback. It really helps us improve the product. Oh and yeah, i am not too sure we are sticking with this forum version. It does take some time getting used to and there are some issues with it, i am not too fond off. There are still positive things about it (like the email-subscription option), however, so we will have to decide on whether we want to switch to an alternative or change the aspects we dislike.


#7

I forgot to ask, have you checked our documentation?

http://www.scipioerp.com/community/developer/


#8

Thanks for the amazing support so far, and I’m glad if it helps you too.

Not exporting ANT_HOME was the problem. It built, and it appeared to load the demo data, but the username/password in the README seems to be wrong. Real progress anyway. Unfortunately I have to stop work on this now as I have a few thousand product pricings to update before business opens at 8am tomorrow.

[UPDATE 12 Jun 2016: For the record on Debian Jessie, if ant is installed from the Debian package, the ANT_HOME environment variable is ‘/usr/share/ant’ and not ‘/usr/local/ant’.]

Oh - yes I did quickly glance at those docs but I’ll get into that deeper soon. I did run into the installer loop bug you mentioned but no big deal.

BTW I upgraded Java from Debian backports, just thought I’d mention it:

apt-get -t jessie-backports install openjdk-8-jdk openjdk-8-jre

Although I’m mostly running Ofbiz 13.07.02 at the moment I think it might be a requirement for Ofbiz 14 (I know I had to do it for Ofbiz for some reason but I can’t remember what) .

Thanks again,
Ged.


#9

Hi Ged,

you should try

username: admin
password:scipio

It is also displayed on the login screen in a tiny info box. It is odd if it is rejected on your end, as it is part of the seed data in general. So perhaps you just mistyped?

OFBiz 14 is still compatible with Java 7 - and so is scipio. We ran regular checks during development.


#10

I completely forgot. If you are connecting to your current database and all, then you may be still on your old username and password :wink:

So if you haven’t change that, then admin:ofbiz may also work. In that case, please make sure that the theme is loaded correctly. You can check against our demo installations:

https://ce.scipioerp.com/admin/
https://ce.scipioerp.com/shop/


#11

Oh, this is embarrassing.

It said ‘admin’ and ‘scipio’ in the README, and they are what I typed. I promise.

I even enabled Javascript and cookies. :smile:

As I said, I loaded the demo data - I haven’t switched to Postgres, in fact I haven’t done anything!

But I’ve just gone back to look at it and I noticed that by some incredible coincidence the hostname that I chose for the new Debian install is also the name of a domain somewhere out on the Internet, which is running something that asks for a login looking just like you might expect from SCIPIO if you connect to port 8443! Fortunately I didn’t get the ID/pass right, or who knows what damage I could have done to some poor fellow’s system before either I realized what I was doing or somebody stopped me!

I thought I’d checked everything, but the browser had substituted .com for .co.uk and I hadn’t spotted that! The thing that got me looking more carefully was your claim that the ID/pass was displayed on the screen. On this screen, it wasn’t. Fairly obviously it wouldn’t be. :smile:

Thanks again, I’ll keep you posted. It might be a few days before I get the time to fire up SCIPIO with my Postgres database.

Oh - that’s what enchiladas look like! :smile:

Ged.


#12

lol - happens to the best of us, i suppose :wink:


#13

http://www.scipioerp.com/community/developer/installation-configuration/

The steps in “SCIPIO ERP Installation” don’t agree with the README (and some look wrong to me).

[Edit] The links under “Optional Configuration” are both 404. In general I wouldn’t even attempt to link to the OfBiz documentation, it will only confuse people.

[Edit2]
http://www.scipioerp.com/community/developer/architecture/components/

s/configuratins/configurations/

…www.scipioerp.com/*

s/seperate/separate/g

[Edit3]
…www.scipioerp.com/community/developer/services/

Half the links to documents at apache.org servers are 404; nagoya.apache.org is gone.

s/usefull/useful/

[Edit4]
Very often when you think you need an apostrophe, you don’t. :smile: In particular, if you can’t replace “it’s” with “it is” in the sentence and have the sentence still make sense, then get rid of the apostrophe. I can’t now find the page which had several examples of erroneous apostrophes, I guess that will be easier for you - just grep for “it’s”.

[Edit5]
…www.scipioerp.com/community/developer/views-requests/screen-widgets-decorators/

Widgets:

“generate the a response object”

[Edit6]
…www.scipioerp.com/community/developer/architecture/

“up-and-foremost” -> “first and foremost”

[Finally for this post]

I’m just jotting these things down here (mostly) as I find them so I don’t have to do it all over again if I jot them down somewhere else. No criticism implied, just tidying up.

This is excellent documentation. Thank you. It’s really useful, if in places a little cryptic. Please don’t be afraid to extend it, and please avoid linking to, er, sites that make your links dead at the drop of a hat.

I really don’t have time for any more now, I wish I did.

Ged.


#14

Thanks for the feedback, Ged.

Yeah, we plan on improving the documentation as we move forward. A proper configuration page is up next on our list. Afterwards we will probably move to a less developer driven end-user documentation. We are still improving on the apps with every release so it will be interesting how we will keep the end-user documentation consistent over time :wink:

Oh and thanks for pointing out when things are a bit cryptic or there are spelling errors - helps us quite a bit :slight_smile:


#15

@Ged: We updated the documentation and added a new configuration page. Thanks again for the valuable input!