Error messge and empty pull down window


#1

As I am testing, I found two things I suspect they are a bug?

  1. Assign GL account (pics AC01 and AC02
    AC01 AC02

  2. Edit Tax Authority Product Rates (pic TA01)
    Drop down window “Category *” is empty (I assume this is a product category and they are defined in scipio.
    As this is a mandatory field, tax percentage cannot be established.

TA01

Wolfgang


#2

Hi,

I’m trying to reproduce it locally. I’ll get back to you in a moment.
Meantime, can you post the error stacktrace?


#3

btw, I am assuming you’ve loaded demo data, is that correct?


#4

I did not load demo data. I started with an empty database and ran ofbizsetup and loaded US GAPP.

But I see the same error message on the demos instance

Error

The Following Errors Occurred

  1. org.ofbiz.webapp.control.RequestHandlerException: Unknown request [null]; this request does not exist or cannot be called directly.

Menu:
Accounting > Chart of Accounts > Navigate Account
There I pick an account and I hit “Assign GL account”

Where can I find error stacktrace?


#5

Nevermind, I found the error and fixed it. It will be available soon in our Github so you’ll only have to pull when we publish it.


#6

Ok, what is the correct command to pull?
By when do you expect it to be on Github?

Thanks, Wolfgang


#7

It’s there already. Just issue git pull in the command line and you’ll the latest changes. Make sure you cd to scipio working directory.