CommunicationEventScreens.xml process error


#1

master:

Misc errors while playing with communications send email, delete.

2017-03-29 21:32:26,049 |http-nio-8443-exec-3 |UtilXml |E| XmlFileLoader: File file:/opt/scipio-erp/applications/party/widget/partymgr/CommunicationEventScreens.xml process error. Line: 173. Error message: cvc-complex-type.2.4.a: Invalid content was found starting with element ‘include-form’. One of ‘{section}’ is expected.


#2

I think I’ve found the issue but I couldn’t reproduce it. I’d like to ensure the fix is correct so I’d appreciate if you can provide me all the steps you’ve done to create the comms that provoke the error.


#3

I clicked:

users -> communications -> find (all defaults)

2017-04-03 09:51:26,284 |http-nio-8443-exec-7 |ControlServlet |T| [[[FindCommunicationEvents(Domain:https://10.2.10.100)] Request Begun, encoding=[UTF-8]- total:0.0,since last(Begin):0.0]]
2017-04-03 09:51:26,314 |http-nio-8443-exec-7 |ConfigXMLReader |I| controller loaded: 0.006s, 246 requests, 101 views in file:/opt/scipio-erp/applications/party/webapp/partymgr/WEB-INF/controller.xml
2017-04-03 09:51:26,330 |http-nio-8443-exec-7 |ConfigXMLReader |I| controller loaded: 0.001s, 40 requests, 19 views in file:/opt/scipio-erp/framework/common/webcommon/WEB-INF/common-controller.xml
2017-04-03 09:51:26,344 |http-nio-8443-exec-7 |ConfigXMLReader |I| controller loaded: 0.0s, 0 requests, 0 views in file:/opt/scipio-erp/framework/common/webcommon/WEB-INF/handlers-controller.xml
2017-04-03 09:51:26,359 |http-nio-8443-exec-7 |ConfigXMLReader |I| controller loaded: 0.001s, 30 requests, 13 views in file:/opt/scipio-erp/framework/common/webcommon/WEB-INF/security-controller.xml
2017-04-03 09:51:26,373 |http-nio-8443-exec-7 |ConfigXMLReader |I| controller loaded: 0.0s, 4 requests, 0 views in file:/opt/scipio-erp/applications/commonext/webapp/WEB-INF/controller.xml
2017-04-03 09:51:26,410 |http-nio-8443-exec-7 |ConfigXMLReader |I| controller loaded: 0.008s, 370 requests, 153 views in file:/opt/scipio-erp/applications/content/webapp/content/WEB-INF/controller.xml
2017-04-03 09:51:26,416 |http-nio-8443-exec-7 |RequestHandler |I| Rendering View [FindCommunicationEvents], sessionId=F6ED2075E45DC630E2DBF4387F8E9385.jvm1
2017-04-03 09:51:26,420 |http-nio-8443-exec-7 |ServiceDispatcher |T| Sync service [partymgr/getUserPreferenceGroup] finished in [1] milliseconds
2017-04-03 09:51:26,458 |http-nio-8443-exec-7 |ServiceDispatcher |T| Sync service [partymgr/getVisualThemeResources] finished in [37] milliseconds
2017-04-03 09:51:26,459 |http-nio-8443-exec-7 |ScreenRenderer |I| loading properties: file:/opt/scipio-erp/framework/widget/config/widgetContextScripts.properties
2017-04-03 09:51:26,568 |http-nio-8443-exec-7 |PrepareNewScreenRenderGroovy |I| Scipio: Preparing new templating API render; clearing request-scope templating vars
2017-04-03 09:51:27,406 |http-nio-8443-exec-7 |UtilXml |E| XmlFileLoader: File file:/opt/scipio-erp/applications/party/widget/partymgr/CommunicationEventScreens.xml process error. Line: 173. Error message: cvc-complex-type.2.4.a: Invalid content was found starting with element ‘include-form’. One of ‘{section}’ is expected.

I then click the demo email: “Why i would use the OFBiz system [9000]”

2017-04-03 09:53:43,422 |http-nio-8443-exec-4 |UtilXml |E| XmlFileLoader: File file:/opt/scipio-erp/applications/party/widget/partymgr/CommunicationEventScreens.xml process error. Line: 173. Error message: cvc-complex-type.2.4.a: Invalid content was found starting with element ‘include-form’. One of ‘{section}’ is expected.

Shows up again. Maybe a minor issue.


#4

thanks mike I fixed the XML error itself in master branch. I did not have time to check if further errors from there, let us know if you see anything.


#5

Re-pulled master, and confirmed. Error gone. It’s refreshing to have a mostly zero byte error log for a change!