Change component mount point


#1

Hi,

I have created a component my-shop which is a shop override component.

I want to change the mount point from mount-point="/my-shop" to mount-point="/my-shop/example"

<webapp name="my-shop"
title="My Shop"
server="default-server"
location="webapp/my-shop"
mount-point="/my-shop/example"
app-bar-display="true"
menu-name="secondary"
/>

I did this, but now nothing is working properly, none of urls works. Shouldn’t this just work fine? I


#2

Hi Amid and welcome to the community.

I think you missed override-mode="remove-overridden-webapp". I just tried locally and every thing works smoothly. Can you try and let me know how it goes?


#3

I tried like this but still I’m having the same issues.
For example when I try to login this:
Error calling event: org.ofbiz.webapp.event.EventHandlerException: Problems processing event: java.lang.IllegalArgumentException: Cookie name [my-shop/example.autoUserLoginId] is a reserved token (Cookie name [my-shop/example.autoUserLoginId] is a reserved token)

what happens if I created component without overriding it? should it work with override-mode="remove-overridden-webapp too?


#4

In my local using a fresh installation works fine. What happens if you clear your browser cookies?

If that doesn’t work can you contact me directly? I am saying this because I think you are from a client of us so we have a different channel for client projects. Check internally to find out how to reach me out.


#5

One more thing, which ScipioERP version are you using?

I am asking this because I think you are using an old one that had a cookie generation bug (cookie names can’t contain slashes if my memory serves me well). That must be fixed if you pull from our official git repository (github), master branch.